Google descobreix una vulnerabilitat en macOS que permet modificar i accedir a les dades del disc dur dels Mac

Macos
APPLE - Archivo
Publicado 5/3/2019 19:08:35CET

MADRID, 5 Mar. (Portaltic/EP) -

Una vulnerabilitat descoberta per l'equip de ciberseguretat 'Project Zero' de Google en el sistema operatiu macOS permet als atacants accedir a les dades emmagatzemades en el disc dur dels ordinadors Mac, cosa que aprofita una bretxa de seguretat en el sistema de transmissió de dades que s'aprofita dels permisos d'Apple.

L'equip de desenvolupadors 'Project Zero' de Google sol donar un termini de 90 dies perquè les companyies arreglin els possibles errors que hagin trobat abans de fer-los públics, i això mateix van fer amb Apple quan li van notificar al novembre una vulnerabilitat detectada en el seu sistema operatiu macOS.

Ara, tres mesos més tard, i després de no rebre resposta d'Apple, Google ha publicat en un fòrum públic de la seva iniciativa de codi obert Chromium els detalls d'aquest error, al qual han denominat 'BuggyCow', acompanyat per una prova de concepte en forma de codi que mostra el problema.

L'error s'ha anomenat així a causa de les inicials del seu procés 'Copy-on-Write' (CoW), pel qual les dades de les aplicacions en curs passen directament al disc dur en lloc de la memòria. Això no només s'aplica a la memòria anònima, sinó també a les adreces d'arxius.

La vulnerabilitat oposada per Google permet que un atacant pugui modificar un arxiu del disc dur sense informar al subsistema de gestió de macOS que garanteix els permisos del sistema. La companyia de Mountain View ha descrit el fet que el sistema permeti dur a terme aquestes còpies entre processos com un "error de seguretat".

El mitjà Wired ha explicat que aquest 'bug' es basa en una llacuna localitzada en la memòria interna d'un ordinador Mac; quan un programa munta un nou sistema d'arxius en un disc dur, carrega tota la col·lecció de dades en lloc d'alterar només un arxiu, fet que l'administrador de memòria no n'està advertit.

Per tant, un pirata informàtic pot desmuntar un sistema d'arxius, tornar a muntar-lo amb dades noves i, en fer-ho, reemplaçar de manera silenciosa la informació que està utilitzant en un codi sensible i en què són necessaris els privilegis del sistema.

L'exexpert de ciberseguretat de l'Agència Nacional de Seguretat dels Estats Units (NSA), Jake Williams, ha comparat a Wired aquest atac amb les cues de recollida d'equipatges dels aeroports. "Reculls la teva maleta a l'aeroport i no la revises", "(l'usuari) assumeix que els continguts no han canviat, però tots dos sabem que els continguts sí que canvien, i aquesta és la vulnerabilitat", segons Williams.

Perquè BuggyCow pugui funcionar, segons detalla Wired, és necessari que l'usuari ja hagi estat envaït per un 'malware', encara que originalment només hagi pogut accedir a permisos molt bàsics.

Per la seva banda, malgrat haver estat informat d'aquest error el passat mes de novembre, de moment Apple no ha trobat cap solució o problema per a aquest error en macOS.

L'actualitat més visitada a Aldia.cat

www.aldia.cat és el portal d'actualitat i notícies de l'Agència Europa Press en català.
© 2019 Europa Press. Està expressament prohibida la redistribució i la redifusió de tots o part dels continguts d'aquesta pàgina web sense previ i exprés consentiment.